Настройка Cisco 2960: устанавливаем коммутатор

Настройка Cisco 2960: устанавливаем коммутатор

Компания Cisco — одна из ведущих транснациональных корпораций на рынке телекоммуникационного оборудования.

Продукция компании Cisco получила признание во всем мире из-за своей надежности и неприхотливости.

Содержание:

Настройка Cisco 2960: в этой статье мы выполним базовую настройку коммутатора. Статья будет полезна всем, начинающим работать с продукцией компании Cisco.

Шаг 1. Подключение оборудования Cisco

Настройка оборудования Cisco весьма специфична и несколько отличается от оборудования других производителей.

Например, для выполнения первичных настроек коммутаторов компании Cisco , нам потребуется фирменный плоский кабель RJ -45 – RS -232 голубого цвета (идет в комплекте с оборудованием) и наличие COM -порта на компьютере, с которого будет производиться настройка.

Большинство материнских плат современных настольных и портативных компьютеров не имеют соответствующего разъема. В таком случае необходимо искать переходник.

В последнее время Cisco стала комплектовать оборудование разъемом Mini — USB для консоли.

Для настройки устройства через порт Mini — USB , необходимо скачать cisco usb console driver.

Шаг 2. Настройка ГиперТерминала

Следующей проблемой, с которой вам придется столкнуться – это отсутствие ГиперТерминала ( HyperTerminal ) в Windows 7/8.

Решением вопроса является копирование папки HyperTerminal c Windows XP (месторасположение каталога – Program Files ) в любой удобный каталог Windows 7/8.

Для запуска программы используется файл hypertrm . exe , который можно найти в той же папке.

Либо использовать программу Putty , которую помимо подключения к Cisco -оборудованию можно использовать для подключения к серверам, маршрутизаторам, пр. с помощью SSH -подключения.

Переходим к подключению. На передней панели коммутатора ищем разъем RJ -45 с подписью « Console », и подключаем кабель.

Включаем питание коммутатора.

Заходим на компьютере в HyperTerminal, выбираем интерфейс разъема (COM1), скорость порта – 9600 Б/с, на все дальнейшие вопросы даем отрицательный ответ (« No »).

Шаг 3. Общие принципы настройки оборудования Cisco

В целях безопасности на коммутаторах Cisco доступно 2 режима ввода команд: пользовательский режим для проверки состояния коммутатора и привилегированный режим (аналог пользователя root в UNIX или администратора в Windows) для изменения конфигурации коммутатора.

Для пользователей, привыкших работать в UNIX-системах, понять в каком режиме они работают не составит труда.

Для пользователей, работающих в Windows дадим пояснение, — если строка перед командной начинается с символа «#», вы в привилегированном режиме.

То же самое касается ввода пароля, как и в UNIX-системах, пароль, который вводит пользователь не отображается на экране.

Для перехода в привилегированный режим служит команда «enable», без кавычек, а для выхода «disable».

Приступим к первичной настройке коммутатора. При первой загрузке устройства мастер установки предложит выполнить пошаговую настройку, отказываемся от этого шага:

Continue with configuration dialog? [yes/no]: no

После чего оказываемся в пользовательский режиме:

Переходим в привилегированный режим, пароль по умолчанию, как правило, отсутствует, поэтому ничего не вводим, а нажимаем «Enter».

Для задания настроек, касающихся всего коммутатора (задание имени коммутатора, IP-адреса, указание сервера синхронизации времени, пр), используется режим глобальной конфигурации, для настройки отдельных интерфейсов существует режим конфигурации интерфейса.

Шаг 4. Базовая настройка Cisco 2960

1. Изменим имя нашего коммутатора (по умолчанию имя Switch):

Switch# configure terminal

Switch(config)# hostname Switch01 ( Задаем имя коммутатора – Switch01)

При наличии множества коммутаторов, рекомендуем в обязательном порядке присваивать уникальные имена для каждого из них.

В последующем это помогает быть уверенным, что конфигурация выполняется именно на нужном устройстве.

Также обращаем ваше внимание на то, что вместо длинных команд как, например, «configure terminal» существуют их короткие аналоги «conf t».

2. Зададим IP-адрес для интерфейса управления коммутатором.

Switch01(config)# interface fa0/0 (указываем интерфейс для настройки)

Switch01(config-if)# no shutdown ( включаем интерфейс )

Switch01(config-if)# ip address 192.168.0.1 255.255.255.0 ( задаем IP- адрес и маску )

Switch01(config-if)# exit (выходим из режима конфигурации интерфейса)

3. Установим пароль для привилегированного режима:

Switch01(config)# enable secret pass1234 ( пароль pass1234)

4. Поскольку данные при telnet соединении передаются в открытом виде, для удаленного подключения к коммутатору будем использовать SSH -соединение позволяющее шифровать весь трафик.

Switch01# clock set 12:00:00 15 April 2015 (Устанавливаем точное текущее время дату)

Switch01# conf t

Switch 01( config )# ip domain name geek — nose . com (Указываем домен, если домена нет пишем любой)

Switch01(config)# crypto key generate rsa ( Выполняем генерацию RSA- ключа для ssh)

Switch01(config)# ip ssh version 2 ( Указываем версию ssh- протокола )

Switch01(config)# ip ssh autentification-retries 3 ( Задаем кол — во попыток подключения по ssh)

Switch01(config)# service password-encryption ( Сохраняем пароли в зашифрованном виде )

Switch 01( config )# line vty 0 2 (Переходим в режим конф-и терминальных линий)

Switch01(config-line)# transport input ssh ( Разрешаем подключение только по ssh)

Switch01(config-line)# exec timeout 20 0 ( Активируем автоматическое разъединение ssh- сессии через 20 минут )

Switch 01( config — line )# end (Выходим из режима конфигурирования)

Switch01# copy running-config startup-config ( Сохраняем настройки )

Выше была описана базовая настройка ssh , с более продвинутой настройкой можно ознакомиться ниже:

Switch01# conf t

Switch01(config)# aaa new-model ( Включаем ААА — протокол )

Switch 01( config )# username root privilege 15 secret pass 1234 (Создаем пользователя root , с максимальным уровнем привилегий – 15, пароль pass 1234)

Switch 01( config )# access — list 01 permit 192.168.0 0.0.0.255 (Создаем правило доступа с названием 01 регламентирующие право заходить по ssh всем хостам сети 192.168.0.0/24; вместо адреса сети можно указать конкретный IP -адрес.

Внимательно подумайте есть ли необходимость в такой настройке для ваших задач.)

Switch 01( config )# line vty 0 2 (Переходим в режим конф-и терминальных линий)

Switch 01( config — line )# privilege level 15 (Разрешаем вход сразу в привилегированный режим )

Switch 01( config — line )# access — class 23 in (Привязываем созданное правило доступа по ssh к терминальной линии )

Switch 01( config — line )# logging synchronous (Очень неудобно когда лог-сообщения коммутатора прерывают ввод команд.

Отключая журнальные сообщения данной командой, коммутатор ждет завершение вводимой команды, а также вывода отчета о ее исполнении, после чего в случае необходимости выводит лог)

Switch 01( config — line )# end (Выходим из режима конфигурирования)

Switch01# copy running-config startup-config ( Сохраняем настройки )

На этом базовая настройка коммутатора Cisco 2960 завершена.

Настройка Cisco за 30 минут с нуля

Настройка Cisco 2960: устанавливаем коммутатор

Настройка Cisco 2960: устанавливаем коммутатор

Read this article in English

Рассмотрим простейший случай, когда требуется подключить 3 отдела фирмы в разные логические сети Vlan, используя один коммутатор уровня доступа Cisco 2960 (Иногда такие коммутаторы называются коммутаторами 2го уровня модели OSI) .

Требуется организовать следующие сети (Vlan):

— отдел продаж (192.168.10.0 255.255.255.0)
— бухгалтерия (192.168.20.0 255.255.255.0)
— администраторы (192.168.100.0 255.255.255.0)
— сеть для управления сетевым оборудованием (192.168.1.0 255.255.255.0)

Видео версия этой статьи на английском языке.

Для справки:
Устройства 2го уровня способны передавать данные только внутри одной сети и осуществляют передачу на основе информации о MAC адресах (например внутри сети 192.168.0.0 /24).

Устройства 3го уровня (например коммутатор Cisco 3560) способны маршрутизировать данные на основе информации об ip адресах и передавать их между различными сетями (например между сетью 192.168.1.0 /24 и сетью 192.168.2.0 /24).

Шаг 0. Очистка конфигурации

(Выполняется только с новым или тестовым оборудованием, так как ведет к полному удалению существующей конфигурации)

После извлечения коммутатора из коробки, подключаемся к нему с помощью консольного кабеля и очищаем текущую конфигурацию, зайдя в привилегированный режим и выполнив команду write erase. (Подробнее о режимах конфигурирования оборудования Cisco можно прочитать в этой статье)

Switch> enable
Switch# write erase
/подтверждение очистки конфигурации/
Switch# reload
/подтверждение/
После выполнения коммутатор должен перезагрузиться в течение 3ех минут, а при старте вывести запрос о начале настройки. Следует отказаться.
Would you like to enter the basic configuration dialog (yes/no): no

Шаг 1. Имя коммутатора

Присвоим коммутатору имя SW-DELTACONFIG-1. (SW – сокращение названия SWitch) Для этого зайдем в режим конфигурирования и введем следующие команды:

Switch #conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch (config)# hostname SW-DELTACONFIG-1
SW-DELTACONFIG-1 (config)#
Название устройства изменилось со «Switch» на «SW-DELTACONFIG-1».

Шаг 2. Интерфейс для удаленного управления

Настраиваем интерфейс для управления коммутатором. По умолчанию это Vlan 1. Для этого присваиваем ip адрес интерфейсу и включаем его командой no shutdown.

SW-DELTACONFIG-1(config)#
interface vlan 1
ip address 192.168.1.11 255.255.255.0
no shutdown
В дальнейшем коммутатор будет доступен именно под адресом 192.168.1.11

Шаг 3. Авторизация пользователей

Настраиваем авторизацию для доступа к устройству. Для этого задаем пароль доступа к привилегированному режиму (знак # рядом с названием устройства), а также создаем учетную запись пользователя и пароль для удаленного подключения.

Задаем пароль для доступа к привилегированному режиму #
SW-DELTACONFIG-1(config)#
enable secret XXXX

Создаем учетную запись для удаленного управления и пароль для нее
username admin secret YYYYY

Включение авторизации, с использованием локальной базы данных пользователей и паролей
SW-DELTACONFIG-1(config)#
line vty 0 4
login local

Для проверки доступности enable режима (#) после ввода этих команд выходим из всех режимов конфигурирования (командой exit или буквой Q в каждом из режимов или сочетанием клавиш Ctrl+Z), оказываемся в первоначальном режиме (обозначается знаком >) и пробуем вновь зайти в привилегированный режим (обозначается знаком #). На запрос пароля вводим тот, который только что задали.

Если ничего не напутали, то видим примерно следующее:
SW-DELTACONFIG-1>enable
Password: XXXXX
SW-DELTACONFIG-1#

Проверку удаленного доступа можно осуществить , запустив из командной строки рабочей станции команду telnet 192.168.1.11. Должен появиться диалог запроса логина и пароля.

После того, как убедитесь, что устройство доступно по протоколу Telnet рекомендую настроить защищенный доступ по протоколу SSH. Подробные инструкции приведены в этой статье.

Шаг 4. Создание Vlan

Создаем Vlan для каждого из отделов и присваиваем им порядковые номера и названия.
SW-DELTACONFIG-1(config)#
vlan 10
name NET_SALES
vlan 20
name NET_ACCOUNT
vlan 100
name NET_ADMIN

Сеть Vlan 1 всегда присутствует на коммутаторе по умолчанию. Она будет использоваться для удаленного управления.

Проверить текущие настройки Vlan можно, выполнив команду sh vlan:
SW-DELTACONFIG-1# show vlan
VLAN Name Status Ports
—- ——————— ——— ——————————-
1 default active Fa0/1, Fa0/2, /. вырезано. /
10 NET_SALES active
20 NET_ACCOUNT active
100 NET_ADMIN active

Убеждаемся, что все созданные нами сети присутствуют в списке.

Шаг 5. Привязка портов

Соотносим порты доступа коммутатора (access port) нужным сетям. На коммутаторе из примера 24 порта FastEthernet и 2 порта Gigabit Ethernet. Для подключения пользователей будут использоваться только Fast Ethernet.

Распределим их следующим образом:

  • первые 6 из них в сеть администраторов (Vlan 100)
  • 12 в сеть отдела продаж (Vlan 10)
  • 6 следующих в сеть для бухгалтерии (Vlan 20).

На каждом интерфейсе для удобства дальнейшего администрирования добавим примечания командой description. Это обычное текстовое поле, которое никак не влияет на другие настройки.
SW-DELTACONFIG-1(config)#
interface range fa 0/1 – 6
switchport access vlan 100
description NET_ADMIN
interface range fa 0/7 – 18
switchport access vlan 10
description NET_SALES
interface range fa 0/19 – 24
switchport access vlan 20
description NET_ACCOUNT

После этого рядом с каждым Vlan будут указаны принадлежащие ему порты, а вывод команды sh vlan должен стать примерно таким:
SW-DELTACONFIG-1# show vlan
VLAN Name Status Ports
—- —————- ——— ——————————-
1 default active
10 NET_SALES active Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18
20 NET_ACCOUNT active Fa0/19, Fa0/20, Fa0/21, Fa0/22, Fa0/23, Fa0/24
100 NET_ADMIN active Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6

Введенными командами мы разделили один физический коммутатор на 4 логических (Vlan 1, Vlan 10, Vlan 20 и Vlan 100).

Важно!
Взаимодействие без использования маршрутизатора будет осуществляться только(!) между портами, принадлежащими одному и тому же Vlan.
Рабочие станции, подключенные в порты, принадлежащие разным Vlan, не смогут взаимодействовать друг с другом даже если будет настроена адресация из одной сети.

Для взаимодействия всех 4ех сетей необходим маршрутизатор, подключенный к коммутатору с помощью trunk порта. Инструкцию по настройке вы найдете здесь. Отличие trunk интерфейса в том, что при передаче по нему трафика каждый пакет помечается номером Vlan, которому принадлежит. Это позволяет устройствам правильно перенаправлять пакеты. На самом коммутаторе порт настраивается следующим образом:
SW-DELTACONFIG-1(config)#
interface GigabitEthernet 0/1
switchport mode trunk
switchport trunk encapsulation dot1q

Если система не принимает последнюю строчку, то это значит, что режим dot1q – единственно возможный, и он настроен по умолчанию.

После выполнения всех описанных действий для проверки подключите две рабочие станции в порты, принадлежащие одному Vlan, например с номером 100, установите на них ip адреса 192.168.100.1 и 192.168.100.2, после чего запустите ping с одной из них на другую. Успешный ответ означает, что все работает как нужно.
Для справки:
Существуют модели коммутаторов 3го уровня модели OSI (Например Cisco 3560), которые объединяют в себе функции коммутатора 2го уровня (access или уровня доступа) и маршрутизатора (устройства 3го уровня). Устройства 3го уровня используются для передачи данных между различными сетями и руководствуются информацией об ip адресах.

Решение аналогичной задачи организации нескольких Vlan на таком коммутаторе рассмотрено в этой статье)

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
FW-DELTACONFIG-1# write
Building configuration.
[OK]

Твой Сетевичок

Все о локальных сетях и сетевом оборудовании

Как подключиться к cisco через cisco на примере cisco 2960

Перед тем, как начать конфигурацию коммутаторов Cisco 2960, на них должна быть выполнена базовая настройка, что включает в себя установку ip-адреса для управления, настройку удаленного доступа по Telnet или SSH, установку даты и времени по протоколу NTP и т.д. Для возможности удаленного управления коммутатором настоятельно рекомендуется использовать протокол SSH (вместо незащищенного Telnet) трафик по которому может быть легко прослушан.

Если же коммутаторы еще не сконфигурированы для возможности удаленного доступа, потребуется подключиться к ним локально с помощью консольного кабеля и выполнить необходимые настройки.

Первоначальная настройка cisco 2960

Cisco 2960 являются коммутаторами с функционалом 2-го уровня модели OSI и, возможно, одними из наиболее используемых коммутаторов по «популярности». В отличие от коммутаторов с набором функций 3-го уровня, они не умеют маршрутизировать в полном объеме, но все же обладают ограниченным набором функциональных возможностей, позволяющим настраивать виртуальные интерфейсы 3-го уровня (предпочтительно для целей управления самим коммутатором) и даже кое-как включать возможность маршрутизации между разными подсетями/vlan (для этого необходимо сделать обновление IOS с набором функций lanbase-routing).

Поскольку коммутаторы Cisco 2960 имеют несколько разных модификаций, в том числе и с гигабитными портами на аплинк, то лучше именно их для соединения коммутаторов между собой. Это даст преимущество в большей пропускной способности между коммутаторами, что является критически важным ввиду больших объемов трафика, передающегося между сетевыми устройствами, в отличие от трафика между коммутатором и конечным пользовательским устройством.

Подключение Cisco 2960 коммутатор – коммутатор

Итак, имеется два коммутатора Cisco 2960 с набором одинаковых VLAN и включенными в них пользовательскими ПК (или другими устройствами).

Идея заключается в том, чтобы соединить хосты обеих коммутаторов для обмена данными между собой. Для этого линк между коммутаторами будем настраивать в режиме транк по стандарту 802.1Q и передавать по нему данные для всех необходимых VLAN-ов.

Авторизуемся на коммутаторе SW1, заходим в режим конфигурирования, затем в подрежим конфигурации интерфейса, подключенного к аналогичному интерфейсу на коммутаторе SW2 и выполняем настройки, как показано на скриншоте:

Первая строчка в режиме конфигурации интерфейса устанавливает название интерфейса – description, вторая переводит в интерфейс в режим транка, и третья — отключает его автонастройку, поскольку конфигурация проводится вручную.

Аналогичную конфигурацию выполняем на втором коммутаторе SW2:

Так как в нашем примере более одного vlan, необходимо явно указать их в режиме конфигурации интерфейса:

При этом следует помнить, что когда вы пытаетесь добавить новый vlan в уже существующий транк (особенно, если в нем присутствует vlan для управления коммутатором), следует быть очень внимательным и не пытаться сделать это с помощью вышеуказанной команды, т.к. можно потерять управление и придется ехать на физическое место установки коммутатора самому или просить кого-то перезагрузить его. Добавление vlan выполняется с помощью команды:

Аналогично, удалить vlan из транка можно с помощью команды:

Теперь пользователи из vlan 10 на SW1 имеют доступность к пользователям того же vlan на SW2. Аналогично и для пользователей из vlan 20 на обоих коммутаторах.

Как подключиться к Cisco через Cisco?

Поскольку конфигурация транка между коммутаторами была выполнена, у нас появилась возможность подключаться к коммутатору через другой коммутатор. Это возможно при условии наличия vlan управления сетевыми устройствами в данном транке и виртуальных интерфейсов, терминирующих данный vlan (то есть наличия ip-адреса, маски подсети и др. на данных интерфейсах vlan).

Например, для подключения со SW1 на SW2 это можно сделать с помощью команды:

Где admin – логин для авторизации на SW2, а — ip-адрес виртуального интерфейса управления на SW2. После ввода пароля вы попадете в непривилегированный режим на SW2. Для входа в привилегированный режим, нужно будет ввести еще enable-пароль.

Настройка коммутатора Cisco Catalyst 2960

На это странице вы найдете большую подборку руководств по настройке коммутаторов Cisco Catalyst 2600.

СОДЕРЖАНИЕ:

  • Быстрый сброс Cisco 2960 на заводские настройки
  • Сброс настроек (пароля) на Cisco 2960 с помощью командной строки
  • Настройка коммутатора Cisco Catalyst 2960 с нуля
  • Как прописать на различные порты Cisco определенные VLAN
  • Создание и настройка VLAN в cisco packet tracer на коммутаторе Cisco Catalyst 2960
  • Настройка ssh подключения к Cisco
  • Как настроить ssh на Cisco Switch catalyst 2960 с помощью командной строки
  • Настройка DHCP на роутере Cisco
  • Настройка Cisco 2960 Netflow
  • Конфигурирование Netflow на роутерах Cisco Router и Solar Winds netflow analyzer
  • Настройка удаленного доступа на Cisco через Web интерфейс
  • Настройка времени на Cisco 2960
  • Настройка QoS очередей на платформах коммутаторов Cisco
  • Настройка PoE на cisco 2960

Быстрый сброс Cisco 2960 на заводские настройки

Сброс настроек (пароля) на Cisco 2960 с помощью командной строки

Подключите терминал или PC с программой эмуляции терминала к консольному порту маршрутизатора. Если пароль на консольный доступ не установлен, наберите show version и запишите значение конфигурационного регистра в самом конце вывода этой команды. Обычно это 0x2102 or 0x102.

Выключите и включите маршрутизатор. Пошлите сигнал Break в течение первых 30 с после включения. Вы должны увидеть приглашение rommon> в командной строке. Если этого не произошло, значит, Вы не послали маршрутизатору сигнал Break. Полезно, кстати, проверить настройки терминального доступа Вашей программы. Они должны быть такими — 9600, 8-«n»-1, no flow control. Наберите confreg. Ответьте ««y»» на вопрос «Do you wish to change configuration[y/n]?» Отвечайте «n» на все остальные вопросы, пока не увидите вопрос «ignore system config info[y/n]?». Ответьте «y». Отвечайте «n» на все оставшиеся вопросы до тех пор, пока не увидите вопрос «change boot characteristics[y/n]?». Ответьте «y». Ответьте «no» на вопрос «Do you wish to change configuration [y/n]?». Напечатайте reset. После перезапуска ответьте «no» на приглашение начать процедуру Setup.

Наберите enable в строке Router>. Вы должны увидеть Router#. Теперь можете посмотреть на конфигурационный файл (команда show startup-config). Если пароль в нем зашифрован, то наберите copy startup-config running-config. Затем наберите conf t и enable secret [новый пароль]. Нажмите sZ. Наберите copy running config startup-config. Наберите config t. Наберите config register 0x2102 (или то значение, которое вы записали). Нажмите sZ. Наберите reload. После перезагрузки должен начать действовать Ваш новый пароль.

Настройка коммутатора Cisco Catalyst 2960 с нуля

Как прописать на различные порты Cisco определенные VLAN

Создание и настройка VLAN в cisco packet tracer на коммутаторе Cisco Catalyst 2960

Настройка ssh подключения к Cisco

Несмотря на то, что устройства Cisco и имеют GUI интерфейс управления, его никто не использует, так как соединение ssh надежнее и подтверждает, что человек, который по нему подключился как минимум знает, что делает. Еще одним из преимуществ является, то что ssh соединение, это просто консольный ввод команд, а значит он кушает меньше трафика и требует меньшую сетевую пропускную способность, в отличии от графического GUI интерфейса, а это означает, что вы легко сможете управлять устройством из мест, где очень слабый интернет.

Как настроить ssh на Cisco Switch catalyst 2960 с помощью командной строки

Настройка DHCP на роутере Cisco

Настройка динамической раздачи IP адресов с помощью сервера DHCP. Суть настройки. Подробная инструкция конфигурирования маршрутизатора. Необходимые настройки для автоматической выдачи IP адресов.

Настройка Cisco 2960 Netflow

Это видео покажет, как сконфигурировать роутер Cisco для экспорта данных NetFlow используя NetFlow version 9 так же известный как Flexible NetFlow.

Конфигурирование Netflow на роутерах Cisco Router и Solar Winds netflow analyzer

Настройка удаленного доступа на Cisco через Web интерфейс

Включение http сервера на оборудование Cisco.

Заходим в привилегированный режим.

Входим в режим конфигурирования.

Router# configure terminal

Создаем access-list 1, в дальнейшем будет использоваться для доступа с определенного ip-адреса.

Router(config)# access-list 1 permit 172.16.1.1

Заводим пользователея myuser с паролем UserPassWord.

Router(config)# username myuser privilege 15 secret UserPassWord

Включаем http сервер с локальной аутентификацией.

Router(config)# ip http server

Router(config)# ip http authentication local

Разрешаем доступ с определенного ip адреса, используя для этого созданный ранее access-list 1.

Router(config)# ip http access-class 1

Включение https сервера на оборудование Cisco

Заходим в привилегированный режим.

Входим в режим конфигурирования.

Router# configure terminal

Задаем имя устройству mycisco

Router(config)# hostname Bullmastiff

Задаем доменное имя — mydomain.com

mycisco(config)# ip domain-name mydomain.com

Создаем access-list 1, в дальнейшем будет использоваться для доступа с определенного ip-адреса.

mycisco(config)# access-list 1 permit 172.16.1.1

Заводим пользователея myuser с паролем UserPassWord.

mycisco(config)# username myuser privilege 15 secret UserPassWord

Выключаем http сервер и включаем https сервер с локальной аутентификацией.

mycisco(config)# no ip http server

mycisco(config)# ip http secure-server

mycisco(config)# ip http authentication local

Разрешаем доступ с определенного ip адреса, используя для этого созданный ранее access-list 1.

mycisco(config)# ip http access-class 1

Вот и все, настройка доступа через веб интерфейс на оборудование cisco завершена.

Настройка времени на Cisco 2960

Установка времени на Cisco производится из привилегированного режима в который вы попадаете командой enable, далее пишем вот такую команду:

clock set 13:53:00 28 nov 2018 где идет время потом месяц и год.

Сразу же сохраним и в память оборудования эту дату командой clock update-calendar иначе после перезагрузки у вас она слетит на 1993 год, работает данная команда не везде, где ее нет нужно использовать NTP сервер.

Для того, чтобы теперь посмотреть время на Cisco вы можете воспользоваться командой: sh clock

Настройка QoS очередей на платформах коммутаторов Cisco

Настройка PoE на cisco 2960

Switch# configure terminal

Switch(config)# interface gigabitethernet2/0/1

Switch(config-if)# power inline port poe-ha

Включение / Выключение PoE на интерфейсе коммутатора:

Ввод auto (значение по умолчанию) настраивает интерфейс на автоматическое распознание требуемой мощности и предоставляет питание, если требуемая мощность доступна. Ввод never запрещает PoE на интерфейсе.

Цены на сайте указаны с НДС.

При безналичном расчете цена не меняется.

Доставка по России, в Казахстан, в Беларусь. По Москве БЕСПЛАТНО!

Оперативный подбор оборудования и аналогов.

Базовая настройка коммутатора Cisco Catalyst

В этой статье я хочу вас познакомить с настройками, с которыми сталкивается любой сетевой инженер, это базовые настройки устройства. Более конкретно рассмотрим базовую настройку коммутатора Cisco Catalyst. В моем примере это Cisco Catalyst 2950, однако базовые настройки для коммутаторов различных платформ одинаковы.

Собираем топологию, как на рисунке.

Для этого нам понадобится rollover-консольный кабель. Подключаем один конец rollover-консольного кабеля к консольному порту RJ-45 на коммутаторе. Другой конец кабеля подключаем к последовательному COM-порту на компьютере. Если на компьютере отсутствует последовательный COM-порт, то вам понадобиться USB–Serial (DB9) переходник. При использовании USB–Serial (DB9) переходника для подключения rollover-консольного кабеля может потребоваться установка драйвера. Его можно скачать с сайта производителя USB–Serial (DB9) переходника. Также нам понадобится знать номер COM-порта для того, чтобы выполнить подключение, его можно посмотреть через Диспетчер устройств после подключения переходника.

Самый лучший переходник USB–Serial (DB9), которым мне довелось пользоваться, это PL2303 фирмы Prolific Technology Inc. Для этого переходника доступны драйвера для всех популярных операционных систем.

Запускаем программу эмуляции терминала — PuTTy. Указываем номер COM-порта, указываем настройки подключения как на рисунке и нажимаем на кнопку Open.

Также необходимо соединить компьютер обычным прямым (straight-through) патч-кордом с портом FastEthernet 0/1 коммутатора, как показано на рисунке.

Итак начнем, включаем питание. Устройство выполняет Power-On-Self-Test (POST) — самотестирование, после чего идет загрузка операционной системы Cisco IOS. В моем случае устройство сброшено к заводским настройкам и на нем нет файла начальной конфигурации (startup-config). При загрузке вы должны увидеть что-то такое:

Если загрузка прошла штатно, то вы должны увидеть приглашение в конфигурационный диалог, мы здесь отвечаем no, потому что будем сами все настраивать.

Собственно после этого мы попадаем в командную строку, где и будем выполнять базовую настройку.

Далее нужно убедиться в том, что коммутатор действительно сброшен к заводским настройкам:

Изначально мы попадаем в пользовательский режим user EXEC. Он имеет ограниченные возможности. Этот режим выглядит таким образом:

Переключаемся в привилегированный режим privileged EXEC, для этого нужно ввести команду:

Переключаемся в режим глобальной конфигурации, для этого вводим команду:

Необходимо задать имя устройству:

Здесь мы указали имя коммутатору switch-floor-1. Рекомендую задавать имя для устройства логично, чтобы потом не перепутать и было через время очевидно, что это за устройство и где оно находится.

Обязательно задаем пароль на привилегированный EXEC режим:

Запрещаем нежелательный поиск в DNS:

Задаем баннероное сообщение MOTD, которое будет выводиться перед входом в систему:

Обратите внимание, что здесь открывающий символ для сообщения это # (решетка), соответственно нужно обязательно баннерное сообщение заканчивать этим знаком # (решетка).

Проверяем настройки доступа. Для этого переключаемся между режимами:

Примечание. Пароль не будет отображаться на экране во время ввода.

Обеспечим возможность удаленного управления коммутатором, для этого необходимо настроить IP-адрес на Switch Virtual Interface (SVI). Перейдем в режим глобальной конфигурации и далее в SVI:

Ограничим доступ к консольному порту. Конфигурация по умолчанию разрешает все консольные подключения без пароля:

Здесь мы задаем пароль для пяти одновременных подключений, в Cisco IOS диапазон указывается через пробел.

Далее настроим IP-адрес на компьютере:

Должно получиться как-то так:

Теперь посмотрим настройки коммутатора:

Проверяем состояние интерфейса управления SVI. Состояние интерфейса VLAN 1 должно быть up/up, что указывает на то, что он активен, и ему должен быть назначен IP-адрес. Обратите внимание, что состояние порта коммутатора FastEthernet0/1 — тоже up, так как к нему подключен компьютер. Поскольку все порты коммутатора изначально принадлежат VLAN 1 по умолчанию, вы можете взаимодействовать с коммутатором по IP-адресу, который был назначен для VLAN 1.

Протестируем подключение между компьютером и коммутатором. Открываем окно командной строки (cmd.exe) на компьютере. В командной строке пишем команду ipconfig для того, чтобы посмотерть сведения об IP-адресе.

Там же в командной строке вводим команду ping, которая используется для проверки подключения.

Обратите внимание, что первый тест прошел неудачно, мы видим сообщение Request timed out. Это связано с тем, что отработал протокол ARP, который используется для получения неизвестного MAC-адреса получателя по известному IP-адресу. Второй тест прошел успешно, поскольку MAC-адрес получателя уже был в ARP-кеше компьютера.

Теперь проверим удаленное подлючение с компьютера на коммутатор через сеть с помощью Telnet. Для этого на комьютере запустим PuTTy и в строке Host Name (or IP address) вводим IP-адрес 192.168.1.2, который был назначен на VLAN 1 коммутатора. Выбираем протокол Telnet для подключения, оставляем порт 23 по умолчанию и нажимаем Open.

Ну что ж, осталось сохранить настройки коммутатора:

А если вам необходимо наоборот удалить сохраненные настройки и сбросить настройки коммутатора к заводским, то воспользуйтесь следующими командами:

Твой Сетевичок

Все о локальных сетях и сетевом оборудовании

Как подключиться к cisco через cisco на примере cisco 2960

Перед тем, как начать конфигурацию коммутаторов Cisco 2960, на них должна быть выполнена базовая настройка, что включает в себя установку ip-адреса для управления, настройку удаленного доступа по Telnet или SSH, установку даты и времени по протоколу NTP и т.д. Для возможности удаленного управления коммутатором настоятельно рекомендуется использовать протокол SSH (вместо незащищенного Telnet) трафик по которому может быть легко прослушан.

Если же коммутаторы еще не сконфигурированы для возможности удаленного доступа, потребуется подключиться к ним локально с помощью консольного кабеля и выполнить необходимые настройки.

Первоначальная настройка cisco 2960

Cisco 2960 являются коммутаторами с функционалом 2-го уровня модели OSI и, возможно, одними из наиболее используемых коммутаторов по «популярности». В отличие от коммутаторов с набором функций 3-го уровня, они не умеют маршрутизировать в полном объеме, но все же обладают ограниченным набором функциональных возможностей, позволяющим настраивать виртуальные интерфейсы 3-го уровня (предпочтительно для целей управления самим коммутатором) и даже кое-как включать возможность маршрутизации между разными подсетями/vlan (для этого необходимо сделать обновление IOS с набором функций lanbase-routing).

Поскольку коммутаторы Cisco 2960 имеют несколько разных модификаций, в том числе и с гигабитными портами на аплинк, то лучше именно их для соединения коммутаторов между собой. Это даст преимущество в большей пропускной способности между коммутаторами, что является критически важным ввиду больших объемов трафика, передающегося между сетевыми устройствами, в отличие от трафика между коммутатором и конечным пользовательским устройством.

Подключение Cisco 2960 коммутатор – коммутатор

Итак, имеется два коммутатора Cisco 2960 с набором одинаковых VLAN и включенными в них пользовательскими ПК (или другими устройствами).

Идея заключается в том, чтобы соединить хосты обеих коммутаторов для обмена данными между собой. Для этого линк между коммутаторами будем настраивать в режиме транк по стандарту 802.1Q и передавать по нему данные для всех необходимых VLAN-ов.

Авторизуемся на коммутаторе SW1, заходим в режим конфигурирования, затем в подрежим конфигурации интерфейса, подключенного к аналогичному интерфейсу на коммутаторе SW2 и выполняем настройки, как показано на скриншоте:

Первая строчка в режиме конфигурации интерфейса устанавливает название интерфейса – description, вторая переводит в интерфейс в режим транка, и третья — отключает его автонастройку, поскольку конфигурация проводится вручную.

Аналогичную конфигурацию выполняем на втором коммутаторе SW2:

Так как в нашем примере более одного vlan, необходимо явно указать их в режиме конфигурации интерфейса:

При этом следует помнить, что когда вы пытаетесь добавить новый vlan в уже существующий транк (особенно, если в нем присутствует vlan для управления коммутатором), следует быть очень внимательным и не пытаться сделать это с помощью вышеуказанной команды, т.к. можно потерять управление и придется ехать на физическое место установки коммутатора самому или просить кого-то перезагрузить его. Добавление vlan выполняется с помощью команды:

Аналогично, удалить vlan из транка можно с помощью команды:

Теперь пользователи из vlan 10 на SW1 имеют доступность к пользователям того же vlan на SW2. Аналогично и для пользователей из vlan 20 на обоих коммутаторах.

Как подключиться к Cisco через Cisco?

Поскольку конфигурация транка между коммутаторами была выполнена, у нас появилась возможность подключаться к коммутатору через другой коммутатор. Это возможно при условии наличия vlan управления сетевыми устройствами в данном транке и виртуальных интерфейсов, терминирующих данный vlan (то есть наличия ip-адреса, маски подсети и др. на данных интерфейсах vlan).

Например, для подключения со SW1 на SW2 это можно сделать с помощью команды:

Где admin – логин для авторизации на SW2, а — ip-адрес виртуального интерфейса управления на SW2. После ввода пароля вы попадете в непривилегированный режим на SW2. Для входа в привилегированный режим, нужно будет ввести еще enable-пароль.

Настройка оборудования

Блог о модемах, роутерах и gpon ont терминалах.

Настройка Vlan на Cisco

Перед тем, как что-то делать, Вы должны понимать что делаете. Поэтому в начале — немного теории.
Что такое VLAN?!
Vlan это аббревиатура от Virtual Local Area Network, что в переводе означает «виртуальная локальная компьютерная сеть». Это логически объединенная группа хостов имеющая общий набор определенных требований и взаимодействующая таким образом, что независимо от их физического местонахождения, хосты видят друг друга так, как если бы они были подключены к широковещательному домену. При этом трафик тегируется в соответствии с правилами стандарта IEEE 802.1Q, т.е. внутрь фрейма помещается тег, содержащий информацию о принадлежности трафика к конкретному Vlan. Фактически, с помощью «влан» или «вилан» (тут уж кто как называет) можно делить сеть на логические сегменты и даже больше — технология позволяет группировать рабочие станции станциям в одну логическую сеть, даже если они находятся в разных сетях физически. При этом между ними спокойно ходит любой трафик — Юникаст, Бродкаст или Мультикаст, но только в пределах этой логической сети.


У каждой виртуальной сети есть свой идентификатор Vlan ID или VID, который используется в стандарте 802.1Q. Стандартный для сетевых устройств диапазон значений Vlan ID — от 0 до 4095. При этом, как правило, VID’ы 0 и 4095 использовать нельзя, так как они зарезервированы для иных задач и доступными остаются номера он 1 до 4094. Кстати, какое бы ни было ограничение на количество поддерживаемых вланов (10, 100 или 1000), их идентификаторы, тем не менее, можно брать из всего диапазона.
На оборудовании Циско различают две группы Vlan — normal-range и extended-range. По русски — обычный и расширенный диапазоны соответственно. В стандартный диапазон входят Vlan — от 1 до 1005, а в расширенный — от 1006 до 4094. При этом надо учитывать, что VID 1002 — 1005 зарезервированы для Token Ring и FDDI Vlan и их занять не получится.

Теперь давайте посмотрим на коммутатор Cisco Catalyst. В своем примере я рассмотрю 2960 c версией IOS 12.2(35)SE5). Заходим на свитч в режим Enable. Набираем команду:

Результатом будет список всех созданных на устройстве влан:

Как Вы можете заметить первым в списке идет Vlan 1 с именем «Defaut». В конфигурации по умолчанию в него включены все порты.
Теперь , чтобы создать свой влан надо зайти в режим конфигурации:

После этого набираем команду:

В моём примере я создаю 11й влан:

Заметьте, что виртуальной сети можно дать имя с помощью команды name.

Удалить влан можно с помощью команды:

Примечание:
На древних версиях IOS все манипуляции с вланами приходилось осуществлять в отдельно базе — vlan database. К счастью, сейчас от этого анахронизма ушли.
Для того, чтобы добавить порт в созданный влан, нужно так же, в режиме конфигурации выбрать нужный порт:

И набрать команду:

Вот как это выглядит на «живом» коммутаторе:

Для управления коммутаторами cisco используется специальный управляющий Vlan. Для его настройки надо создать его в списке вланов, как описано выше, затем в режиме конфигурации набрать команду:

Этим Вы создадите управляющую виртуальную сеть на коммутаторе. Теперь устройству надо присвоить IP-адрес:

После этого не забудьте поднять интерфейс, так как он по умолчанию выключен:

Пример настройки управления на коммутаторе Cisco 2960:

Не забудьте — для того, чтобы управление коммутатором было доступно, необходимо добавить в этот Vlan хотя бы один порт, либо, создать на других коммутаторах, с которых Вы хотите управлять этим устройством.

Помогло? Посоветуйте друзьям!

Настройка Vlan на Cisco : 8 комментариев

Я бы использовал формулировку «добавить VLAN на порт», нежели добавить порт во VLAN. Т.к. на каждый порт можно накрутить множество VLAN

Тогда это уже будет либо транк, либо гибрид, а тут — аксесс как-никак.

Тем не менее, даже по строкам конфигурации, сначала конфигурится физ.интерфейс и на него прикручивается VLAN. Во всяком случае, одмин поймет о чем идет речь

Во всех описаниях настроек дается присвоение IP статического. А тут надо динамический. И никак. В interface vlan1 вводился ip address dhcp не берет ip и все. Интерфейс активен. В show config пишет interface Vlan1
ip address dhcp и тишина.

Здравствуйте! Я в этом деле человек новый, так что прошу не орать на меня. Прочитал статью, хорошо написано, но я не понял как понять в какой порт воткнута sfpшка. Для этого я должен знать vlan ? просто у меня имеется конфигурация и мне надо найти в ней в какой порт вставлен sfp модуль. Заранее спасибо.

Никита — здравствуйте. Вы же работаете с конкретной моделью коммутатора или маршрутизатора, то есть знаете модель — посмотрите в спецификации, какие порты идут под sfp.

прекрасно покажет все воткнутые в коробку SFP.

Спасибо! Не получалось настроить управляющий vlan, помогли!

Ссылка на основную публикацию